ATC-SIM Helper script and chain commands gone? (ATC-SIM)

submitted by Evan to /forum/atc-sim

So I was playing ATC-SIM for the first time in a while a few weeks ago, and it was great, was using the Firefox ATC-SIM Helper (1.6) script to chain commands etc, and all worked well.

Just tried again today and that feature isn't working. I also noticed that now aircraft that hit a waypoint continue straight, not circling. Read that was a new feature here in another thread.

Is that was possibly is causing this script to no longer work? Not sure how many people here use it but it's great. The plane highlighting is still working, so the script is working... but the chain command function seems to have stopped.

Would appreciate any help!

all comments

ce2121 1 point

Here's a temporary fix!

In the helper script, change line 397 from: if((unsafeWindow.G_objPlanes[ID][7] == 0) && (fnMyDistance(ID, unsafeWindow.G_objPlanes[ID][12]) < 15)) To: if((unsafeWindow.G_objPlanes[ID][7] == 0) && unsafeWindow.G_objPlanes[ID][11] === null)

It was broken because now, when a plane crosses a fix, the 'cleared to' fix is set to NULL. Jay's code does this more than 15 units of distance away from a fix, so the Helper script never gets a chance to catch it and send the plane on it's way to the next fix in the route. This code change looks for planes that have a route and have recently passed a fix and have had their 'cleared to' fix set to NULL. :)

Evan 0 points

Thanks so much for the tip! This works great. =]

0 points

J'apprécie votre impact en m'aidant à comprendre comment le résoudre beaucoup mieux et plus efficacement. J'aimerais aussi avoir plus d'informations sur le casino en ligne jackpot city et les bonus avec promotions pour être prêt à jouer au vrai jeu!

imaboss3112 0 points

Command chaining isn't implemented yet?

Evan 0 points

Ah sorry if I was unclear.

There's actually a script add-on for Firefox and Chrome (though I can only find it for Chrome at the moment, oddly enough) that has allowed chain commands for years. Really surprised it never caught on more as that seems to be the number one feature request.

Here it is for Chrome if you wanna try it out (though like I said, it seems that with the recent change that removes aircraft 'circling' waypoints, it inadvertently disabled this important chain command feature of the script.


Anyone else have any info on this?

theredbaron 0 points

Ever since Jay started implementing some upgrades the command chaining feature on the Grease Monkey script has stopped working.

theredbaron 0 points

I come back to this forum every few days really hoping for a fix or news that command chaining has been implemented in the default sim. Until then I can't get my ATC fix! :)

av8nut 0 points

I know Jay has been working on the chain commands, from the sounds of it on other posts. The fact that it's not working for you may mean that soon something will be implemented on the default ATC-SIM, without the need for the script. Maybe.

jlrwi 0 points

I'd guess that there is not necessarily a connection between the changed waypoint behavior and the script no longer working, except that there are many programming changes that have to happen to implement new features for the sim.